Downloads

The ActionGUI's plugin

ActionGUI projects are developed using a maven plugin.

  • To generate ActionGUI applications you need to have installed maven (version 3.0.4 or higher) on your local machine. Check the ActionGUI's User manual (Requirements) for up-to-date information about how to access the ActionGUI's maven repository. 
  • Additionally,
    • To deploy ActionGUI applications in your local machine you need to have installed JDK/JRE 7. You also need to have both a MySQL server and a Java web server (like Glassfish or WildFly) running in your local machine. 
    • Although not necessary, you may find convenient to use Netbeans (7.3. or higher) to work with the ActionGUI's plugin. Netbeans supports very nicely maven projects. We have develop three Netbeans textual editors for writing the three different models of the ActionGUI applications (installation instructions here).

The ActionGUI's virtual machine

If you prefer to use ActionGUI without modifying your system, you can simply use the ActionGUI's virtual machine. Check the ActionGUI virtual machine's How to for up-to-date information about how to work with the ActionGUI's plugin within VirtualBox.

Licensing Agreement

By downloading either the ActionGUI's plugin or the ActionGUI's virtual machine, you acknowledge that you have read and accepted the terms of the Licensing Agreement.